Blog personal de Aleix Serra. Todos los contenidos de mi creación están bajo licencia CC "by".

Y recuerda que un blog se alimenta de tus comentarios ;)

Problema con WPAU al actualizar WP a 2.7

chapa_wordpress head-news1

Desde hace casi un mes, he tenido diversos problemas para seguir con los posts del blog.

Primero fué el fallo y cambio seguido del acceso a internet (solucionado),

luego tuve un problema serio con otros programas instalados en el directorio raiz, que me obligaron a resetar ciertos archivos no muy recomendables de ser reseteados 😛 ,

luego fué una cagada mía, jugando con el WPAU de WordPress (ficheros que se originan gracias a la actualización automática y que, si has tocado algo que no deberías, acostumbran a dar dolores de cabeza) con el CHMOD 777 (niños, no lo intenteis en casa sin la supervisión de un adulto !!!); cagada que lo solucionaron a la perfección los chicos de Imaginalia (gracias Carles y Samu, sois unos cracks),

luego fué un problemón con la actualización de WP a 2.7 (problema que me vino por toquetear demasiado y el maldito WPAU se me escoñó. Y eso me ha tenido en vilo durante más de dos semanas y cientos de páginas). En este problema en concreto, del cual no he encontrado apenas soluciones en español, es el que quiero explicar algo por encima para quien se encuentre en la misma situación que yo, al menos no vaya tan perdido.

A saber:

No podía actualizar con el Automatic Upgrade porque me aparecía un “click here to run the cleanup process before continuing” que no me dejaba continuar.
SOLUCIÓN: (siempre en mi caso, ojo) borrar la carpeta “wpau-backup” del directorio FTP. Visto en los foros de WordPress (en inglés).

Seguidamente, al volver a intentar la actualización, me daba otro error, en concreto “ERROR -> Could not put the site into maintenance mode” cuando intentaba entrar en modo “mantenimiento” (en concreto el error del log era este:

Task Name: maintmode
Task Description: Puts the site into maintenance mode
Task Status: Failed
Task Start Date: 2009-01-06 22:37:42
Task End Date: 2009-01-06 22:37:42
Task Log:
Putting the site into maintenance mode /xxx/xxxxx/xxxxxx/xxxx/xxxx/xxx/wp-content/plugins/wordpress-automatic-upgrade
Copying /xx/xxxx/xxxx/xxx/xxxx/xxx/index.php to /xx/xxxx/xxxx/xxx/xxxx/xxx/index.php.wpau.bak
The file was successfully copied
Moving the maintenance file to root
ERROR -> Could not put the site into maintenance mode
)

SOLUCIÓN: Probando varias opciones, la única que me funcionó fué la de administrar permisos 777 (si, si…parece mentira, pero es así…..sólo eso :o) a toda la carpeta raiz (visto en Techie Buzz WordPress Plugin Support Forums). En el mismo hilo del foro ofrecen algunas otras opciones y/o caminos cuando tenemos problemas con el WPAU.

IMPORTANTE: Es importante remarcar que si cambiais permisos a 777 de toda la raiz, no olvidaros de volver a dar los permisos que antes teníais (el 644 es el más normal que tengais) !!!

Ahora parece que todo empieza a funcionar bien como antes. Empieza bien el año 😉

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*